Caseys | Delayed check-in tagging affecting campaign processing

Incident Report for Caseys

Resolved

This incident has been resolved.
Posted Aug 28, 2026 - 09:23 PDT

Monitoring

The fix is in place and holding. Tagging on the Casey's environment is running at normal speed, and newly tagged check-ins have been verified as correct. We have increased processing capacity and the backlog of untagged check-ins is draining, oldest first. Check-ins and points continue to work normally. Because of the size of the backlog, some campaign progress and rewards may still appear later than usual today; we expect tagging to be back within normal timeframes by tomorrow morning. Next update by tomorrow morning, or sooner if anything changes.
Posted Aug 27, 2026 - 07:54 PDT

Identified

We have identified the cause of the delayed check-in tagging on the Casey's environment: a change introduced in a recent platform update. We have rolled the affected component back to its previous version for Casey's and confirmed that tagging is running at normal speed and producing correct results. The backlog of untagged check-ins is now being processed. Check-ins and points continue to work normally; some campaign progress and rewards may still appear later than usual until the backlog clears. Next update within 1 hour.
Posted Aug 27, 2026 - 07:53 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 27, 2026 - 07:50 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 27, 2026 - 07:26 PDT

Update

We are continuing to investigate this issue.
Posted Aug 27, 2026 - 06:45 PDT

Investigating

We are currently experiencing delays in processing campaigns. Our team is actively working to resolve the issue as quickly as possible.
Customer Impact:
• Campaigns may take longer than usual to be sent out.
• You might experience delays in receiving real-time data and updates.
• The Punchh Dashboard will show that your campaign is scheduled instead of processing or processed after than the scheduled start time
• If you're still seeing this behavior 2 hours after the scheduled start time, please submit a support case

We apologize for any inconvenience this may cause and appreciate your patience. Updates will be provided as more information becomes available. Thank you for your understanding.
Posted Aug 27, 2026 - 06:32 PDT